Linkis执行任务包多 No plugin found

提问者:帅平 问题分类:大数据
报如下错误EngineConnPluginNotFoundException:errorCode:70063
engineplugin.common.loader.exception.EngineConnPluginNotFoundException:errCode:70063,desc:No plugin
found, please check your configuration ip:cdh01 ,port:9103 ,serviceKind:linkis-cg-engineplugin

 您阅读本篇文章共花了: 

1 个回答
烟波
烟波
Linkis默认安装包中不包含该引擎连接器插件,解决办法:安装的时候没有修改对应引擎的Version导致,所以默认插入到db里面的引擎类型为默认版本,而编译出来的版本不是默认版本导致。具体修改步骤:
1、cd /appcom/Install/dss.conf-linkis/linkis/lib

2、 /linkis-engineconn-plugins/,修改dist目录下的v2.1.1 目录名 修改为v1.2.1 修改plugin目录下的子目录名2.1.1 为

默认版本的1.2.1。如果是Spark需要相应修改dist/v2.4.3 和plugin/2.4.3。最后重启engineplugin服务。
发布于:6个月前 (10-11) IP属地:四川省
蔓延的小思念
蔓延的小思念
对于 appcon-1引擎连接器当前Linkis并未提供相应的插件,用户可从dss获取该引擎连接器的插件包,Linkis 默认支持的插件即安装包下载可参考:
https://linkis.apache.org/zh-CN/blog/2022/04/15/how-to-download-engineconn-plugin

具体操作为:将dss/dss-appconns目录下的linkis-engineplugin-appconn.zip复制到linkis/lib/linkis-engineconn-plugins/,解压并重命名成appconn,修改appconn的dist/v1/conf/linkis-engineconn.properties配置,补全linkis相关配置
发布于:6个月前 (10-11) IP属地:四川省
与你无关
与你无关
安装插件可以参考官方文档:
https://linkis.apache.org/zh-CN/docs/latest/deployment/install-engineconn
发布于:6个月前 (10-11) IP属地:四川省
我来回答