使用bizlog-sdk日志框架的时候,缺少很多依赖

提问者:帅平 问题分类:微服务

根据bizlog-sdk的文档,准备使用bizlog-sdk日志框架,文档里面提了添加maven依赖

<dependency>
			<groupId>io.github.mouzt</groupId>
			<artifactId>bizlog-sdk</artifactId>
			<version>3.0.1</version>
		</dependency>

后直接在代码里面编码接口,根据这样使用之后,启动项目报错:

Caused by: java.lang.ClassNotFoundException: org.springframework.context.expression.CachedExpressionEvaluator


1 个回答
Rae
Rae 管理员

1、这里需要添加spring-context的依赖,如下:

<dependency>
            <groupId>org.springframework</groupId>
            <artifactId>spring-context</artifactId>
        </dependency>

2、检查下springboot的版本,建议为2.x的版本,例如:

<parent>
		<groupId>org.springframework.boot</groupId>
		<artifactId>spring-boot-starter-parent</artifactId>
		<version>2.3.4.RELEASE</version>
	</parent>

发布于:2个月前 (10-13)
我来回答