使用idea编写spark程序在本地运行的时候报错:Scala signature package has wrong version

提问者:帅平 问题分类:微服务

使用idea编写spark程序在本地运行的时候报错:

scalac: error while loading package, Scala signature package has wrong version
 expected: 5.0
 found: 5.2 in package.class

看起来是版本冲突了,怎么解决?

1 个回答
等你许久
等你许久

这里的原因主要是在maven中引入的scala版本不,因此修改下对应的scala版本即可,例如:

<dependency>
      <groupId>org.scala-lang</groupId>
      <artifactId>scala-library</artifactId>
      <version>2.13.9</version>
    </dependency>

发布于:2个月前 (12-01)
我来回答